import re
regex = re.compile(r"(?<!^)[A-Z]", flags=re.MULTILINE)
test_str = ("CamelCaseForTheWin\n"
"ACar\n"
"BuyACar\n"
"XML\n"
"SimpleXML\n\n")
subst = "_$0"
result = regex.sub(subst, test_str)
if result:
print(result)