re = /(?<!^)[A-Z]/m
str = 'CamelCaseForTheWin
ACar
BuyACar
XML
SimpleXML
'
subst = '_$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result