import Foundation
let pattern = #"(?<!^)[A-Z]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CamelCaseForTheWin
ACar
BuyACar
XML
SimpleXML
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)