package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+").*?(\([A-Z]\),?) *?(?:,|$)`)
var str = `11" x 8" x 21" (S), 12" x 9" x 21" (M), 13" x 10" x 21" (L)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}