const regex = /(\d+").*?(\([A-Z]\),?) *?(?:,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+").*?(\\([A-Z]\\),?) *?(?:,|$)', 'gm')
const str = `11" x 8" x 21" (S), 12" x 9" x 21" (M), 13" x 10" x 21" (L)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}