$re = '/(\d+").*?(\([A-Z]\),?) *?(?:,|$)/m';
$str = '11" x 8" x 21" (S), 12" x 9" x 21" (M), 13" x 10" x 21" (L)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);