re = /(\d+").*?(\([A-Z]\),?) *?(?:,|$)/m
str = '11" x 8" x 21" (S), 12" x 9" x 21" (M), 13" x 10" x 21" (L)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end