using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(144\d|145\d|207[67|]|UCF\d)\d{6}\b";
string input = @" rocket RoCKEt
hi 2077234567
This is a rocket.
ROCKET's engine";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}