re = /\b(144\d|145\d|207[67|]|UCF\d)\d{6}\b/m
str = ' rocket RoCKEt
hi 2077234567
This is a rocket.
ROCKET\'s engine'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end