$re = '/\b(144\d|145\d|207[67|]|UCF\d)\d{6}\b/m';
$str = ' rocket RoCKEt
hi 2077234567
This is a rocket.
ROCKET\'s engine';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);