import re
regex = re.compile(r"\b(144\d|145\d|207[67|]|UCF\d)\d{6}\b", flags=re.MULTILINE)
test_str = (" rocket RoCKEt\n"
"hi 2077234567\n"
"This is a rocket.\n"
"ROCKET's engine")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")