using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]{3,20}(?:,[A-Z]{3,20})*$";
string input = @"JOHN,MARK,EDDIE
JOHN
JOHN,
JOHN MARK
JOHN,MARK,EDDIE,JOHN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}