import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]{3,20}(?:,[A-Z]{3,20})*$";
final String string = "JOHN,MARK,EDDIE\n"
+ "JOHN\n\n\n\n"
+ "JOHN,\n"
+ "JOHN MARK\n"
+ "JOHN,MARK,EDDIE,JOHN";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}