$re = '/^[A-Z]{3,20}(?:,[A-Z]{3,20})*$/m';
$str = 'JOHN,MARK,EDDIE
JOHN
JOHN,
JOHN MARK
JOHN,MARK,EDDIE,JOHN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);