re = /^[A-Z]{3,20}(?:,[A-Z]{3,20})*$/m
str = 'JOHN,MARK,EDDIE
JOHN
JOHN,
JOHN MARK
JOHN,MARK,EDDIE,JOHN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end