using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Heading +(1).*(?:\r?\n(?! *Heading).*)*?\r?\n.*?SubheadingB: *(.*)";
string input = @"Heading -1
SubheadingB: SomethingBB
SubheadingC: SomethingCC
Heading 0
SubheadingA: SomethingDD
SubheadingB: SomethingEE
SubheadingC: SomethingFF
Heading 1
SubheadingA: SomethingX
SubheadingB: SomethingY
SubheadingC: SomethingZ
Heading 2
SubheadingA: SomethingGG
SubheadingB: SomethingHH
Heading 3
SubheadingA: SomethingJJ
SubheadingB: SomethingKK
SubheadingC: SomethingLL";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}