const regex = /^Heading +(1).*(?:\r?\n(?! *Heading).*)*?\r?\n.*?SubheadingB: *(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Heading +(1).*(?:\\r?\\n(?! *Heading).*)*?\\r?\\n.*?SubheadingB: *(.*)', 'gm')
const str = `Heading -1
SubheadingB: SomethingBB
SubheadingC: SomethingCC
Heading 0
SubheadingA: SomethingDD
SubheadingB: SomethingEE
SubheadingC: SomethingFF
Heading 1
SubheadingA: SomethingX
SubheadingB: SomethingY
SubheadingC: SomethingZ
Heading 2
SubheadingA: SomethingGG
SubheadingB: SomethingHH
Heading 3
SubheadingA: SomethingJJ
SubheadingB: SomethingKK
SubheadingC: SomethingLL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}