import re
regex = re.compile(r"^Heading +(1).*(?:\r?\n(?! *Heading).*)*?\r?\n.*?SubheadingB: *(.*)", flags=re.MULTILINE)
test_str = ("Heading -1\n"
" SubheadingB: SomethingBB\n"
" SubheadingC: SomethingCC\n\n"
"Heading 0\n"
" SubheadingA: SomethingDD\n"
" SubheadingB: SomethingEE\n"
" SubheadingC: SomethingFF\n\n"
"Heading 1\n"
" SubheadingA: SomethingX\n"
" SubheadingB: SomethingY\n"
" SubheadingC: SomethingZ\n\n"
"Heading 2\n"
" SubheadingA: SomethingGG\n"
" SubheadingB: SomethingHH\n\n"
"Heading 3\n"
" SubheadingA: SomethingJJ\n"
" SubheadingB: SomethingKK\n"
" SubheadingC: SomethingLL")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")