using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?) - ([0-9]+) - # [0-9]+ (.*?).pdf";
string input = @"ABC 2020 Sec. Fund - 2021 - # 1 Doe, John.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}