$re = '/(.*?) - ([0-9]+) - # [0-9]+ (.*?).pdf/m';
$str = 'ABC 2020 Sec. Fund - 2021 - # 1 Doe, John.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);