// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?) - ([0-9]+) - # [0-9]+ (.*?).pdf").unwrap();
let string = "ABC 2020 Sec. Fund - 2021 - # 1 Doe, John.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}