re = /(.*?) - ([0-9]+) - # [0-9]+ (.*?).pdf/m
str = 'ABC 2020 Sec. Fund - 2021 - # 1 Doe, John.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end