package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:A|A |AA F|M)\d+(?:-\d+|\+)`)
var str = `A25-54 plus affinities targeting,Demo (AA F21-54),
A25-49 Artist Affinity Targeting,M21-49 plus,plus plus A 21+ targeting`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}