import re
regex = re.compile(r"(?:A|A |AA F|M)\d+(?:-\d+|\+)", flags=re.MULTILINE)
test_str = ("A25-54 plus affinities targeting,Demo (AA F21-54),\n"
"A25-49 Artist Affinity Targeting,M21-49 plus,plus plus A 21+ targeting")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")