#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sU)(.+\n)\n\s*\n"
Local $sString = " Test Test TestTester TestTestt Test Test TestTestTestTest: 29724 @erq" & @CRLF & _
" Test Test we Test Test, iuow, 0202220" & @CRLF & _
" Test Test 962ert64" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest " & @CRLF & _
" Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest " & @CRLF & _
" Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest " & @CRLF & _
"Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")