$re = '/(.+\n)\n\s*\n/sU';
$str = ' Test Test TestTester TestTestt Test Test TestTestTestTest: 29724 @erq
Test Test we Test Test, iuow, 0202220
Test Test 962ert64
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);