import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+\\n)\\n\\s*\\n";
final String string = " Test Test TestTester TestTestt Test Test TestTestTestTest: 29724 @erq\n"
+ " Test Test we Test Test, iuow, 0202220\n"
+ " Test Test 962ert64\n\n\n\n\n\n\n"
+ " Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest \n"
+ " Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest \n"
+ " Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest \n"
+ "Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}