re = /(.+\n)\n\s*\n/
str = ' Test Test TestTester TestTestt Test Test TestTestTestTest: 29724 @erq
Test Test we Test Test, iuow, 0202220
Test Test 962ert64
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest
Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest Test Test TestTestTestTest '
# Print the match result
str.match(re) do |match|
puts match.to_s
end