using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^remind me +(?:.*?\b(to|that|about|its|it's)\b *)?(.*)$";
string input = @"remind me in 24 hours test
remind me in 24 hours to test
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}