// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^remind me +(?:.*?\b(to|that|about|its|it's)\b *)?(.*)$").unwrap();
let string = "remind me in 24 hours test
remind me in 24 hours to test
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}