$re = '/^remind me +(?:.*?\b(to|that|about|its|it\'s)\b *)?(.*)$/m';
$str = 'remind me in 24 hours test
remind me in 24 hours to test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);