package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^remind me +(?:.*?\b(to|that|about|its|it's)\b *)?(.*)$`)
var str = `remind me in 24 hours test
remind me in 24 hours to test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}