using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s?[a-z0-9]+\s+[a-z0-9]+\s+([a-z0-9]+)\s?$";
string input = @"qwe rty abc
qwe rty abc
qwe rty abc def
qwe rty abc def
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}