re = /^\s?[a-z0-9]+\s+[a-z0-9]+\s+([a-z0-9]+)\s?$/m
str = 'qwe rty abc
qwe rty abc
qwe rty abc def
qwe rty abc def
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end