$re = '/^\s?[a-z0-9]+\s+[a-z0-9]+\s+([a-z0-9]+)\s?$/m';
$str = 'qwe rty abc
qwe rty abc
qwe rty abc def
qwe rty abc def
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);