import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s?[a-z0-9]+\\s+[a-z0-9]+\\s+([a-z0-9]+)\\s?$";
final String string = "qwe rty abc\n"
+ "qwe rty abc \n"
+ "qwe rty abc def\n"
+ "qwe rty abc def\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}