const regex = /((\$?[A-Z]+\$?\d+)(:(\$?[A-Z]+\$?\d+))?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\$?[A-Z]+\\$?\\d+)(:(\\$?[A-Z]+\\$?\\d+))?)', 'gm')
const str = `=A\$13:B4+\$BC\$12+\$DE2+F2:G2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}