// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\$?[A-Z]+\$?\d+)(:(\$?[A-Z]+\$?\d+))?)").unwrap();
let string = "=A$13:B4+$BC$12+$DE2+F2:G2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}