re = /((\$?[A-Z]+\$?\d+)(:(\$?[A-Z]+\$?\d+))?)/m
str = '=A$13:B4+$BC$12+$DE2+F2:G2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end