$re = '/((\$?[A-Z]+\$?\d+)(:(\$?[A-Z]+\$?\d+))?)/m';
$str = '=A$13:B4+$BC$12+$DE2+F2:G2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);