using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" --> adapter01 \((?P<AdapterAddress>.+)\)$";
string input = @"server01 (server01:7575)
--> 123Device (server01.1)
--> adapter01 (server01.2)
--> BCDDevice (server01.3)";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}