const regex = / --> adapter01 \((?P<AdapterAddress>.+)\)$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' --> adapter01 \\((?P<AdapterAddress>.+)\\)$', 'm')
const str = `server01 (server01:7575)
--> 123Device (server01.1)
--> adapter01 (server01.2)
--> BCDDevice (server01.3)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}