import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " --> adapter01 \\((?P<AdapterAddress>.+)\\)$";
final String string = "server01 (server01:7575)\n"
+ " --> 123Device (server01.1)\n"
+ " --> adapter01 (server01.2)\n"
+ " --> BCDDevice (server01.3)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}