$re = '/ --> adapter01 \((?P<AdapterAddress>.+)\)$/m';
$str = 'server01 (server01:7575)
--> 123Device (server01.1)
--> adapter01 (server01.2)
--> BCDDevice (server01.3)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);