#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d\s\d+\s\S+\s(?<srcaddr>(?:[0-9]{1,3}\.){3}[0-9]{1,3})\s(?<dstaddr>(?:[0-9]{1,3}\.){3}[0-9]{1,3})\s(?<srcport>\d+)\s(?<dstport>\d+)\s.*$"
Local $sString = "2 593497967075 eni-00ac176e167382d9e 172.31.3.217 52.25.130.38 5439 8870 6 184 235311 1645025131 1645025186 ACCEPT OK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")