const regex = /\d\s\d+\s\S+\s(?<srcaddr>(?:[0-9]{1,3}\.){3}[0-9]{1,3})\s(?<dstaddr>(?:[0-9]{1,3}\.){3}[0-9]{1,3})\s(?<srcport>\d+)\s(?<dstport>\d+)\s.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\s\\d+\\s\\S+\\s(?<srcaddr>(?:[0-9]{1,3}\\.){3}[0-9]{1,3})\\s(?<dstaddr>(?:[0-9]{1,3}\\.){3}[0-9]{1,3})\\s(?<srcport>\\d+)\\s(?<dstport>\\d+)\\s.*$', 'gm')
const str = `2 593497967075 eni-00ac176e167382d9e 172.31.3.217 52.25.130.38 5439 8870 6 184 235311 1645025131 1645025186 ACCEPT OK`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}