import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\s\\d+\\s\\S+\\s(?<srcaddr>(?:[0-9]{1,3}\\.){3}[0-9]{1,3})\\s(?<dstaddr>(?:[0-9]{1,3}\\.){3}[0-9]{1,3})\\s(?<srcport>\\d+)\\s(?<dstport>\\d+)\\s.*$";
final String string = "2 593497967075 eni-00ac176e167382d9e 172.31.3.217 52.25.130.38 5439 8870 6 184 235311 1645025131 1645025186 ACCEPT OK";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}