// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d\s\d+\s\S+\s(?<srcaddr>(?:[0-9]{1,3}\.){3}[0-9]{1,3})\s(?<dstaddr>(?:[0-9]{1,3}\.){3}[0-9]{1,3})\s(?<srcport>\d+)\s(?<dstport>\d+)\s.*$").unwrap();
let string = "2 593497967075 eni-00ac176e167382d9e 172.31.3.217 52.25.130.38 5439 8870 6 184 235311 1645025131 1645025186 ACCEPT OK";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}