using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\.AddMyString\("".*?""\))(?![\s\S\r]*\1)";
string input = @"var myObject = new MyClass();
myObject.AddMyString(""Test"");
myObject.AddMyString(""Computer"");
myObject.AddMyString(""Printer"");
[...]
myObject.AddMyString(""Scanner"");
myObject.AddMyString(""Test"");
[...]
myObject.AddMyString(""Computer"");
myObject.AddMyString(""Speakers"");";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}