$re = '/(\.AddMyString\(".*?"\))(?![\s\S\r]*\1)/m';
$str = 'var myObject = new MyClass();
myObject.AddMyString("Test");
myObject.AddMyString("Computer");
myObject.AddMyString("Printer");
[...]
myObject.AddMyString("Scanner");
myObject.AddMyString("Test");
[...]
myObject.AddMyString("Computer");
myObject.AddMyString("Speakers");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);